Top menu

‘DeviceLock database has a format that is not supported by the current server version’ error when installing DeviceLock Enterprise Server, or modifying its configuration in DeviceLock Enterprise Server options

DESCRIPTION

Database creation process fails with ‘DeviceLock Database has an unsupported format’ error when installing DeviceLock Enterprise Server, or modifying its configuration in DeviceLock Enterprise Server options.

COMMENTS

The error indicates that the database specified in the ‘Database name’ parameter already exists but it was created by a more recent version of DeviceLock Enterprise Server. This mostly happens when after the downgrade of DeviceLock Enterprise Server to a previous version. However, the database version cannot be downgraded.

RECOMMENDATIONS

1.    Use the version of DeviceLock Enterprise Server the current database was created for;
2.    Create a new database with the applicable version of DeviceLock Enterprise Server.