Top menu

Topic: «High CPU for DLserver.exe», How to troubleshoot

« Previous topic | Next topic »

Bob Murching


User profile

Posts: 20
Joined: 03/15/2011
Sorry for the many questions...

We are seeing very high CPU utilization for DLserver.exe - this is on a fast quad core box connected to extremely fast disk, and only ~15 clients monitored. All four cores are 80% to 85%. I am not sure how to troubleshoot this. When the service is stopped, CPU drops. When it's started, it jumps back up. We made sure to remove AV software just to eliminate one possible source of conflict. Windows Event logs are clear. (This is Server 2008 R2.)
Posted: 03/21/2011 22:02:43

Top

Jennifer Bousquet
Technical Support Engineer
Editor


User profile

Posts: 388
Joined: 07/20/2006
What Ports/Device Types do you have configured to capture Audit and Shadow data?
(ie; are you only capturing data for certain ports/device types, or all?)

What options have you configured within the DLEServer Audit Log and Shadow Log Viewer Settings? Have you enabled the Control Log Size parameter? (including setting the maximum log size and parameter for what DLEServer should do once that maximum is reached.)
Posted: 03/21/2011 22:27:41

Top

Bob Murching


User profile

Posts: 20
Joined: 03/15/2011
It's a mix - for devices, only some offline policies, otherwise strictly auditing/shadowing. Ditto for protocols. There is some shadowing going on as well as auditing, however across the test group of PCs, totalling about 1000 audit log records and maybe 15-20 shadowed documents (all small ones) per day at the current rate. This seems like a relatively small amount of data to capture when spread out across a day so I am not sure why CPU is so high.
Posted: 03/22/2011 20:06:27

Top

Jennifer Bousquet
Technical Support Engineer
Editor


User profile

Posts: 388
Joined: 07/20/2006
Forwarding to Technical Support so that additional information and reporting can be gathered for review.

Thank you for using DeviceLock!
Posted: 03/22/2011 20:09:26

Top